IPB

Здравствуйте, гость ( Вход | Регистрация )

Важные объявления

 
Ответить в данную темуНачать новую тему
> quake3, ошибка при запуске
§Renegat†§
сообщение 15.4.2008, 8:54    [ Вставить ник в форму быстрого ответа ]
Сообщение #1


Рожденный в сумраке
***

Группа: Новобранец
Сообщений: 66
Регистрация: 15.1.2007
ICQ: 203643448
Пользователь №: 119
Спасибо сказали: 0 раз(а)

Дистрибутив:
ubuntu 7.10



Репутация: 0


при запуске кваки вылазит ошибка:
Sys_Error: GLimp_Init() - could not load OpenGL subsystem
как ето исправить?

Код
Q3 1.32b linux-i386 Nov 14 2002
----- FS_Startup -----
Current search path:
/home/doromones/.q3a/baseq3
/usr/local/games/quake3/baseq3/pak8.pk3 (9 files)
/usr/local/games/quake3/baseq3/pak7.pk3 (4 files)
/usr/local/games/quake3/baseq3/pak6.pk3 (64 files)
/usr/local/games/quake3/baseq3/pak5.pk3 (7 files)
/usr/local/games/quake3/baseq3/pak4.pk3 (272 files)
/usr/local/games/quake3/baseq3/pak3.pk3 (4 files)
/usr/local/games/quake3/baseq3/pak2.pk3 (148 files)
/usr/local/games/quake3/baseq3/pak1.pk3 (26 files)
/usr/local/games/quake3/baseq3/pak0.pk3 (3539 files)
/usr/local/games/quake3/baseq3
./quake3.x86/baseq3

----------------------
4073 files in pk3 files
execing default.cfg
couldn't exec q3config.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok

------- Input Initialization -------
Joystick is not active.
------------------------------------
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
...loading libGL.so.1: Initializing OpenGL display
...setting mode 3: 640 480
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 640x480
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Couldn't get a visual
...WARNING: could not set the given mode (3)
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
----- CL_Shutdown -----
-----------------------
Sys_Error: GLimp_Init() - could not load OpenGL subsystem
Перейти в начало страницы
Вставить ник
+Цитировать сообщение
Зарегистрируйтесь, чтобы скрыть этот рекламный блок.
§Renegat†§
сообщение 15.4.2008, 10:50    [ Вставить ник в форму быстрого ответа ]
Сообщение #2


Рожденный в сумраке
***

Группа: Новобранец
Сообщений: 66
Регистрация: 15.1.2007
ICQ: 203643448
Пользователь №: 119
Спасибо сказали: 0 раз(а)

Дистрибутив:
ubuntu 7.10



Репутация: 0


а все разобрался, надо было драйвера малость помучать
сделал все по етой статейке
Прикрепленные файлы
Прикрепленный файл  HowTo__ATI_Radeon_open_source________.html.tar.gz ( 28.88 килобайт ) Кол-во скачиваний: 85
 
Перейти в начало страницы
Вставить ник
+Цитировать сообщение
dima-linux
сообщение 18.4.2008, 10:11    [ Вставить ник в форму быстрого ответа ]
Сообщение #3


Новичок
*

Группа: Новобранец
Сообщений: 5
Регистрация: 19.3.2008
Пользователь №: 1070
Спасибо сказали: 0 раз(а)

Дистрибутив:
Linux Mint
Jabber ID:
[email protected]



Репутация: 0


1. Включи модуль GLX в конфе иксов.
2. Скачай ioquake.
Перейти в начало страницы
Вставить ник
+Цитировать сообщение
Ka4_0k
сообщение 10.2.2009, 21:08    [ Вставить ник в форму быстрого ответа ]
Сообщение #4


Новичок
*

Группа: Новобранец
Сообщений: 11
Регистрация: 8.2.2009
Из: Днепропетровск
ICQ: 404787586
Пользователь №: 1970
Спасибо сказали: 0 раз(а)

Дистрибутив:
Gentoo



Репутация: 0


Здравствуйте! При запуске игры возникает такая ошибка
./ioquake3.x86_64: error while loading shared libraries: libopenal.so.0: cannot open shared object file: No such file or directory
Дистрибутив Ubuntu 8.10 x86-64
Перейти в начало страницы
Вставить ник
+Цитировать сообщение
dip56245
сообщение 10.2.2009, 23:58    [ Вставить ник в форму быстрого ответа ]
Сообщение #5


Programmer
****

Группа: Старейшины
Сообщений: 481
Регистрация: 28.9.2005
ICQ: 82591163
Пользователь №: 2
Спасибо сказали: 2 раз(а)

Дистрибутив:
SuSE
Jabber ID:
[email protected]



Репутация: 2


нет библиотеки OpenAL (Audio Library)...
Перейти в начало страницы
Вставить ник
+Цитировать сообщение
Ka4_0k
сообщение 11.2.2009, 16:26    [ Вставить ник в форму быстрого ответа ]
Сообщение #6


Новичок
*

Группа: Новобранец
Сообщений: 11
Регистрация: 8.2.2009
Из: Днепропетровск
ICQ: 404787586
Пользователь №: 1970
Спасибо сказали: 0 раз(а)

Дистрибутив:
Gentoo



Репутация: 0


Библиотека была, просто у меня была версия новее чем надо.
Починил таким образом.
cd /usr/lib
sudo ln -s libopenal.so.1 libopenal.so.0
Перейти в начало страницы
Вставить ник
+Цитировать сообщение

Ответить в данную темуНачать новую тему
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 



RSS Текстовая версия Сейчас: 22.8.2019, 12:26    


BonAppetit - кулинарные авторские фоторецепты  ITO-info